• About Us
  • Blog
  • Basket
  • Account
  • Sign In
  •  

API Supported Versions

The following table shows the required prerequiste compiler versions to use our APIs. Versions not stated below are either unusable or have not been tested to confirm they work correctly.

API Compiler Version Swig Version Gcc/G++ Version
.NET .NET 4.0+ N/A N/A
PHP PHP v5 or PHP v7 2.0+ for PHP v5, 3.0.13+ for PHP v7 4.8.4+
Python Python 2.7+ 2.0+ 4.8.4+
Perl Perl 5.0.1+ 2.0+ 4.8.4+
Java 1.6+ (1.7+ if using Automatic Updates) N/A N/A
C Gcc 4.8.4+ N/A 4.8.4+
Node.JS Node v6.5.0+ 2.0+ 4.8.4+
Varnish Varnish 4.1.7+ N/A 4.8.4+
GO GO 1.8+ 3.0.12+ 5.0.0+
.NET Standard 1.6+ N/A N/A
Nginx Nginx 1.12.1+ N/A 4.8.4+