• About Us
  • Blog
  • Basket
  • Account
  • Sign In
  •  

Forums

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 08 Aug 2019 02:12 AM by  AimanKhan
Please help with data file
 2 Replies
Sort:
You are not authorized to post a reply.
Author Messages

finalfrontierchannel



New Member


Posts:
New Member


--
27 Jul 2019 01:31 PM
    Hi,

    I have registered for the Lite product and downloaded the file of type HashTrieV​34, which is the only one available on the download page.

    I then installed the packages through Nuget as described in the installation section, the version is 51Degrees.mobi-web 3.2.21.1

    I then try to load the file through the stream factory:
    DataSet dataSet = StreamFactory.Create(fileName)
    but it throws an exception with description:
    Version mismatch. Data is version '1441826.2359296.1260519424.0' for '3.1.0.0,3.2.0.0' reader

    I have also downloaded the code from github here: https://github.com/51Degrees/dotNET...Detection, when I run the example it also fails to load the data file. I've tried the ones supplied, and the one I've downloaded. By default it tries to load this file: /data/51Degrees-LiteV3.2.dat

    Is there a problem with the library, or am I doing something wrong, or using the incorrect data file?
    0

    JoshGrew



    New Member


    Posts:34
    New Member


    --
    30 Jul 2019 09:55 AM
    The version of Lite data that is provided on the website is for our Hash algorithm. This is available for .Net in a different repository here:

    https://github.com/51Degrees/Device...sualStudio

    The hash algorithm is only supported by our C API and uses a SWIG wrapper for .Net.

    If you wish to use the NuGet packages you will need to include the mobi-data package. This contains our Pattern (.dat) data file.

    Any questions let me know.
    0

    AimanKhan



    New Member


    Posts:1
    New Member


    --
    08 Aug 2019 02:12 AM
    First thing would be to check if the versions of the data file you currently have in the data folder are empty. By default they are included as empty templates when you clone the repository unless you have Git LFS installed.

    0
    You are not authorized to post a reply.