• About Us
  • Blog
  • Basket
  • Account
  • Sign In
  •  

Forums

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 06 Jul 2017 03:50 PM by  Dmitry
[Closed] Nexus phones' isMobile property is false
 4 Replies
Sort:
Topic is locked
Author Messages

Dmitry



New Member


Posts:3
New Member


--
05 Jul 2017 10:49 PM
    Hi All,

    I have core version 3.2.17.2 and data version 3.2.17.5 installed in the solution. Nexus phones (tested on Nexus 6 actual phone and Nexus 4, 5, 6 as chrome devices) are not detected as mobile devices.

    Can anyone advise?


    Kind Regards,

    Dmitry
    0

    Lily



    New Member


    Posts:9
    New Member


    --
    06 Jul 2017 08:54 AM
    Hi Dmitry,

    Thanks for contacting 51Degrees, could you send the User-Agent of some example devices you are having issues with. I can then investigate this further.
    0

    Dmitry



    New Member


    Posts:3
    New Member


    --
    06 Jul 2017 12:54 PM
    Hi Lily,
    Thank you for the response.
    The user agents are:

    The actual nexus 6 phone:
    Mozilla/5.0 (Linux; Android 7.0; Nexus 6 Build/NBD91P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.90 Mobile Safari/537.36

    Nexus 4 Chrome emulation:
    Mozilla/5.0 (Linux; Android 4.4.2; Nexus 4 Build/KOT49H) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Mobile Safari/537.36

    Nexus 5 Chrome emulation:
    Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Mobile Safari/537.36

    Nexus 6 Chrome emulation:
    Mozilla/5.0 (Linux; Android 5.1.1; Nexus 6 Build/LYZ28E) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Mobile Safari/537.36

    Nexus 7 Chrome emulation:
    Mozilla/5.0 (Linux; Android 4.3; Nexus 7 Build/JSS15Q) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

    Kind Regards,
    Dmitry
    0

    Lily



    New Member


    Posts:9
    New Member


    --
    06 Jul 2017 01:44 PM
    Hi Dimitry,

    Thanks for this information I have ran these User-Agents through our User_agent tester here https://51degrees.com/resources/use...ent-tester and as you can see, we do detect them all as IsMobile = True

    Can you confirm the date of the data file you are using.

    Also are you putting the raw User-Agent into your code, if there are stray quote marks for example, this will effect the result and will give you an incorrect detection.

    Many thanks,

    Lily
    0

    Dmitry



    New Member


    Posts:3
    New Member


    --
    06 Jul 2017 03:50 PM
    Hi Lily,
    Actually, it is not a bug. We found the piece of code in the solution where IsMobile property is overwritten based on some logic. So this is not an issue anymore.

    Thank you for your help.

    Kind Regards,
    Dmitry
    0
    Topic is locked