• About Us
  • Blog
  • Basket
  • Account
  • Sign In
  •  

Forums

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 09 Apr 2012 02:47 PM by  Fabio Pagano
(SOLVED) Map Control: clarification
 9 Replies
Sort:
Topic is locked
Author Messages

Fabio Pagano



New Member


Posts:
New Member


--
05 Apr 2012 09:39 AM
    I'm trying to use for the first time the map control. I have put the map control on a web page and i've tried to position it on Rome coordinates (Lat=41.912497000000002, Lon=12.494202). The following page appears (it's not positioned on Rome): http://img196.imageshack.us/img196/9095/image26q.png The source html code is: <form id="Form1" runat="server"> <mob:Map ID="Map1" runat="server"> </mob:Map> <br /> <mob:Label ID="Label1" runat="server" Text="Label"></mob:Label> </form> The CodeBehind code in Page_Load is: Partial Class map Inherits MobilePage Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load 'Rome Dim Lat As Double = 41.912497000000002 Dim Lon As Double = 12.494202 If Not Page.IsPostBack Then Map1.Latitude = Lat Map1.Longitude = Lon End If Label1.Text = String.Concat(Map1.Latitude.ToString, " - ", Map1.Longitude.ToString) End Sub End Class I'm using framework version 2.1.0.2. May you help me? Thank you.
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    05 Apr 2012 11:03 AM
    Hi Fabio,

    I am getting the expected result, could you please try with the static html having Lat and Long set like this,

    <mob:Map ID="Map1" runat="server" Latitude="41.912497000000002" Longitude="12.494202">
            </mob:Map>

    Have attached the output.

    Thanks,
    Murali
    0

    Fabio Pagano



    New Member


    Posts:
    New Member


    --
    05 Apr 2012 12:07 PM
    I've had the same result. Here is the screenshot with the code:

    http://img196.imageshack.us/img196/4193/image30l.png

    (May you kindly tell me how to attach an image on post?)

    Thank you.
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    05 Apr 2012 12:58 PM
    Hi Fabio,

    Surprise, we are doing further analysis on this as an source please mail me the solution (compressed) to following mail id.

    You can add images by using the Image option  as shown in the screen shot.

    My mail id: murali@51degrees.mobi

    Thanks,
    Murali
    0

    Fabio Pagano



    New Member


    Posts:
    New Member


    --
    05 Apr 2012 01:01 PM
    I think i have found the explanation. I have international settings as "Italian", so the decimal separator is "," (column) instead of "." (dot) and the coordinates are expressed as  "12.345" not "12,345". Changing international settings to English, the map has worked.

    I think you have to consider international settings when managing coordinates numbers.

    Thank you.
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    05 Apr 2012 01:12 PM
    Hi Fabio,

    Glad you found the solution, thanks for your update and will consider your suggestion.

    Thanks,
    Murali 
    0

    Fabio Pagano



    New Member


    Posts:
    New Member


    --
    05 Apr 2012 03:57 PM
    My temporary workaround (change machine regional settings, setting "." as a decimal separator instead of "," used here in Italy) works only if i use visual studio web server. IIS uses a different method for globalization.

    So, as a temporary workaround independent from machine regional settings, waiting for your permanent solution, i've added Culture="en-US" to the "@Page" directive (in the page where the map is displayed) and it seems to work. Please note that without this workaround, the map control is almost unusable in nations where decimal separator is not ".".

    Thank you.
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    05 Apr 2012 04:09 PM
    Fabio,

     We are working on it, once the new build is available with the fix we will let you know.

    Thanks,
    Murali
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    07 Apr 2012 05:04 PM
    Hi Fabio,

    The new release of Framework - 2.1.1.1 has the enhancements to the Map and Location control to enable Globalization support, which resolves the issue you have mentioned in Map control.

    Please let me know if you have any questions.

    Thanks,
    Murali
    0

    Fabio Pagano



    New Member


    Posts:
    New Member


    --
    09 Apr 2012 02:47 PM
    It has worked.

    Thank you for your kind and great support.
    0
    Topic is locked