Go to previous topic
Go to next topic
Last Post 19 Apr 2012 11:59 AM by  Murali Setty
(CLOSED) About Framework
 7 Replies
Author Messages

rahul



New Member


Posts:
New Member


--
19 Apr 2012 09:46 AM
    I am using 51 degree framework for developing mobile wap site. But I am facing problem of colour change for any 51 degree controls.
    If i set any color for any control like button or label which is set to white or red it get set in development side but when i access that page on mobile the color get set to default color green.
    Is there any way i can set my color to which i set
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    19 Apr 2012 09:57 AM
    Hi Rahul,

    By default the Mobile Web application projects will have the themes configured, due to that by default controls are having the Green colour based styles applied.

    You can disable the default themes configured from the file App_Data\51Degrees.mobi.config file by commenting out the themes config section. Once done you will see the controls having the styles applied as defined by your page design.

    Thanks,
    Murali
    0

    rahul



    New Member


    Posts:
    New Member


    --
    19 Apr 2012 10:50 AM
    Thanks.
    My default colour get change frm green to black. but still i am having problem. if i set red color to my label then shows only black color.
    no color change has been done for it.

    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    19 Apr 2012 10:52 AM
    Rahul,

    Could you please share the sample of the html which shows how you are defining the styles?

    Thanks,
    Murali
    0

    rahul



    New Member


    Posts:
    New Member


    --
    19 Apr 2012 10:58 AM
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head id="Head1" runat="server">
        </head>
     <body>
        <form id="Form1" runat="server">
          <mob:Panel ID="Panel1" runat="server" >
              <mob:Label ID="Label1" runat="server" Text="Welcome" ForeColor="#FF0066" ></mob:Label>
    </mob:Panel>
       </form>
    </body>
    </html>
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    19 Apr 2012 11:20 AM
    Hi Rahul,

    Few questions to understand better,

    1. Does your web.config has the configuration related Handlers like,
          <add verb="GET" path="I.axd" type="FiftyOne.Framework.Mobile.Includes.IncludesHandler, FiftyOne.Framework" ...
          <add verb="GET" path="P.axd" type="FiftyOne.Framework.Image.ImageHandler, FiftyOne.Framework ...

    2. What is the base class of Page code behind class?
    3. What is the .Net Mobile Framework version installed?

    Verify the page output (html source) of the page, to ensure it is not missing the patterns (not exactly the same content) as highlighted in the picture


    Thanks,
    Murali
    0

    rahul



    New Member


    Posts:
    New Member


    --
    19 Apr 2012 11:51 AM
    yes all that highlighted part is coming in my page source and i downloaded mobile framework yesterday only.
    and my code file is in C#
    0

    Murali Setty



    New Member


    Posts:
    New Member


    --
    19 Apr 2012 11:59 AM
    Could you please mail me the solution (compressed version) after removing the confidential information like passwords if it has. So that I can verify the issue. The information exchanged is not giving any clues. You can also remove other pages except the page which has issue, to reduce the compressed file size. Mail id to send solution(compressed): murali@51degrees.mobi Thanks, Murali
    0


    ---