• About Us
  • Blog
  • Basket
  • Account
  • Sign In


Search this forum:
You are not authorized to create a new topic
 Last Post
2 Replies and 257 Views (CLOSED) Incredibly bad performance with latest data file    257  2 Started by  Owen Marsh We use the API in memory mode, and recently updated to the latest data file in our dev environment. This environment does not see a huge amount of traffic (400 requests per second) and previously had an average latency of less than 5 milliseconds. Upon restarting the server with the new data file, average latency never went below 80 milliseconds, and often went over 1 second. The new data file was the only change. We updated to the latest version of the API (, but that ...
2 257
by  JoshGrewJump to last post
14 Dec 2017 03:49 PM
4 Replies and 501 Views (CLOSED) How to identify failed device detections    501  4 Started by  gib Hello, What would be the best way to identify a failed/not correct detection Thank you in advance.
4 501
by  gibJump to last post
07 Jul 2017 07:07 AM
4 Replies and 471 Views [Closed] Default Property Values    471  4 Started by  TreSensaCoreDev When the default property is returned for a 'match.getValues(propertyName)' call, I would like to use null instead. The TrieProvider class contains a 'getDefaultPropertyValue(String propertyName)' method, which makes this easy to accomplish. (Simply check the returned value against the default.) Can something similar be done with the regular Provider or Match classes
4 471
by  LizHJump to last post
18 Jun 2017 09:06 PM
4 Replies and 553 Views (Closed) Using Autoupdate in application on WebLogic server fails due to incorrect certificate  553  4 Started by  JBraund Good morning, We are seeing an issue when attempting to implement the 51Degrees Autoupdate service in our application. We are running a J2EE application in the WebLogic application server. When autoupdate runs, we receive the following error: <Security> <BEA-090504> <Certificate chain received from 51degrees.com - failed hostname verification check. Certificate contained *.azurewebsites.net bu t check expected 51degrees.com> When using the ...
4 553
by  JBraundJump to last post
28 Mar 2017 10:37 AM
2 Replies and 260 Views (Closed) Memory leak  260  2 Started by  Jonathan Blais Hi, We recently moved over to your in production and we quickly ran into massive memory leak issues. I documented everything on your Github https://github.com/51Degrees/Java-Device-Detection/issues/3 By looking at your Github commits history, it seems like you also experienced memory leaks while testing in December (although they might be unrelated). Is that something you guys have been fixing Happy to help if you need us to perform more tests internally. You gu...
2 260
by  Joseph DixJump to last post
27 Mar 2017 03:15 PM
2 Replies and 1155 Views Cannot download 51degrees data file  1155  2 Started by  Greg Hi, We started seeing the following error in our logs when attempting to download the 51degrees.dat using the auto updater. ERROR &91;FiftyOneDataFileUpdateScheduler&93; An error occurred while updating the 51Degrees data file. This may need performing manually. fiftyone.mobile.detection.AutoUpdateException: Device data download failed: java.security.cert.CertificateException: No subject alternative DNS name matching 51degrees.com found. at fiftyone.mobile.detection.AutoUpdate...
2 1155
by  GerhardJump to last post
03 Aug 2016 11:00 AM
1 Replies and 867 Views (CLOSED) Useragents & dropwizard    867  1 Started by  captmega I've reviewed the documentation available, checked the forum, and tried reading through the javadoc, but still can't quite figure out how to get started. I'd like to evaluate using this library / service in a dropwizard project (http://dropwizard.io) It uses embedded jetty and jackson to provide api endpoints, and I can easily get the user agent header string from a request. Could you provide some sample code for how I might initialize the WebProvider I tried using this as a guide, but i...
1 867
by  EdwardJump to last post
16 Nov 2015 07:56 AM
6 Replies and 2099 Views (CLOSED) Configuring the AutoUpdate service to use a proxy server    2099  6 Started by  JBraund Good afternoon, Following on from our previous question (https://51degrees.com/support/forum/g/posts/t/3949/-SOLVED--IP-Address-or-URL-to-whitelist-for-automatic-updates), our service provider has advised us that we would need to use a proxy to connect to the 51 Degrees end point. How can we configure the AutoUpdate service to use a proxy server when accessing the end point Thanks, James
6 2099
by  EdwardJump to last post
22 Oct 2015 12:20 AM
5 Replies and 790 Views (SOLVED) Using 51Degrees API with Jetty server in embedded mode    790  5 Started by  Sergey.Maks Hi I try to use 51Degrees java API with premium .trie file under Jetty. I need use Jetty server in embedded mode. What I can use this device detection API in this case. I tried use 51Degrees in this simple java app: class Program { public static class Servlet extends HttpServlet { Override public void init() throws ServletException { super.init(); //as I understood from your doc's, I need to init 51Degrees providers in this method ...
5 790
by  MikeJump to last post
02 Sep 2015 02:47 PM
3 Replies and 873 Views (SOLVED) Java Webapp - Client Side Overrides not available    873  3 Started by  JoelFGS I'm trying to get the client side overrides to work in my webapp so I can detect iOS device models. The core.js returned by FiftyOneDegreesServlet never contains the FODPO javascript, even when being requested from an iOS device. It's not entirely clear to me what needs to happen to get this to work since the documentation for the Java code is out of date. Here's what I'm doing: Map /51D/* to FiftyOneDegreesServlet. Installed the Listener and Filter. I have verified that the license file...
3 873
by  MikeJump to last post
03 Aug 2015 10:02 AM
1 Replies and 1133 Views (SOLVED) Pom file for 51Degrees.detection.webapp has incorrect dependency    1133  1 Started by  Keith The pom file for 51Degrees.detection.webapp has the following dependency for the core module: com.fiftyonedegrees 51Degrees.detection.core The groupId is incorrect. It should be com.51Degrees This is in as well. I did not check any other versions.
1 1133
by  MikeJump to last post
07 Nov 2014 11:08 PM
1 Replies and 824 Views (SOLVED) Upgrade from lite to premium    824  1 Started by  eeweise I am using the Java library via maven. Is upgrading just a matter of pointing to the premium version of the database or is the java library different as well I plan on testing using the lite version and if it all looks good, upgrade to the paid version. thanks Eric Weise
1 824
by  EdwardJump to last post
14 Feb 2014 12:00 PM
0 Replies and 782 Views 51Degrees Java device detector feature request    782  0 Started by  Mike If you would like to see a particular feature added to our Java device detector you can post this feature here.
0 782
by  James RosewellJump to last post
25 Aug 2009 08:17 PM
0 Replies and 574 Views Posting Guidelines for 51Degrees - Java forum    574  0 Started by  Mike Welcome to forum concerning Java implementation of 51Degrees device detector. In this forum you can ask us questions related to our Java open source detector, suggest a feature or report a bug. We have a Java Documentation section on our website that contains a lot of useful information on how to set up, configure and use the detector and plugins. When reporting a problem or a bug please supply as much relevant information as possible so that we will be able to investigate and reproduce th...
0 574
by  James RosewellJump to last post
25 Aug 2009 08:17 PM
0 Replies and 839 Views (CLOSED) Problem accessing sample data with lite    839  0 Started by  Andy N I am evaluating 51Degrees and whether we should purchase the premium license. However,I am having trouble accessing the sample data file. I have the lite jar, and am able to run my code against the light internal data. I've downloaded the sample data (both the gzip and .dat, not sure which one I need).When I try accessing the gzip file, my system hangs, when I try accessing the .dat file, I get a stack trace with java.util.regex.PatternSyntaxException: Illegal/unsupported escape sequence near i...
0 839
by  James RosewellJump to last post
25 Aug 2009 08:17 PM
You are not authorized to create a new topic

RSS Feed Available