• About Us
  • Blog
  • Basket
  • Account
  • Sign In
  •  

Java V3.1 Documentation

You are viewing an old version of the documentation. For the latest, please go here: Java V3.2

Prerequisites

Minimum Requirements

Environment capable of running Java.

The source code is written using JDK 1.6.

Test Platform Configurations

Operating System Java Environment Version IDE Version (Core Functionality) IDE Version (Servlet Functionality)
OsX 10.9.2

Java 1.7.0_17

Java SE Runtime Environment (build 1.7.0_17-b02)

Java HotSpot 64-bit Server VM(build 23.7-b01)

Eclipse IDE 4.2.2

NetBeans IDE 8.0

GlassFish Server 4

Java EE 7 Web

Windows XP SP3

Java 1.7.0_55

Java SE Runtime Environment (build 1.7.0_55-b14)

Java HotSpot Client VM (build 24.55-b03)

Eclipse IDE Version: Kepler Service Release 2 ?
Ubuntu 14.04

Java 1.7.0_55

OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)

OpenJDK 64-BitServer VM(build 24.51-b03)

Eclipse IDE 3.8.1

NetBeans IDE 8.0

GlassFish Server 4 / Tomcat 7

Java EE 7 Web